w

Content Warning

Jeżeli na swojej stronie publikujesz treści niestosowne dla młodszych odwiedzających to z pomocą tej wtyczki nie tylko możesz poinformować odwiedzających o tym ale i wymusić potwierdzenie przeczytania ostrzeżenia.

Ostrzeżenie wyświetlane jest przy wejściu na stronę w formie okienka popup za pomocą skryptu Thickbox, który WordPress ma natywnie na pokładzie, tutaj plus dla autora, że nie ładuje niepotrzebnie swojej wersji. Popup z ostrzeżeniem prezentuje się jak poniżej na screenie. Pytanie, treść ostrzeżenia i dwa przyciski, oba służą do potwierdzenia przeczytania ostrzeżenia, tyle, że ten po prawej zamyka popup i umożliwia dalsze przeglądanie strony a ten po lewej przekierowuje do wyszukiwarki Google (ale można to łatwo zmienić).

Content Warning popup

Treść pytania, treść ostrzeżenia (tagi HTML dozwolone) i tekst na obu przyciskach możemy dowolnie zmodyfikować. Także nie ma tutaj potrzeby zabawy z plikiem tłumaczenia bo wsio możemy przetłumaczyć z poziomu strony ustawień i w każdej chwili zmienić. Prócz samej treści, na stronie ustawień możemy ustawić dokąd ma zostać przekierowany odwiedzający (dowolny wewnętrzny i zewnętrzny adres url), po ilu sekundach „ciasteczko” ma zostać usunięte (jego usunięcie = ponowne wyświetlenie popupa) oraz w razie potrzeby wyłączyć wyświetlanie popupa.

Guerrilla’s Content Warning

Napisane przez Przemysław Matras

Zafascynowany możliwościami jakie zapewnia niebieska kropla jak i zafascynowany rozwojem WordPress'a w kolejnych wersjach. Nałogowy słuchacz muzyki gatunku EBM i industrial.

Komentarze

Dodaj komentarz

Ładowanie…

0

WordCamp Warszawa 2014: Zgłoś się jako prelegent

WordUp-ploty + 1# spotkanie GWWP